Network Design

Planning a Network with Different Users,
Hosts, and Services

OBJECTIVES

The objective of this lab is to demonstrate the basics of designing a network while consider-
ing the users, services, and locations of the hosts.

OVERVIEW

Optimizing the design of a network is a major issue. Simulations are usually used to ana-
lyze the conceptual design of the network. The initial conceptual design is usually refined
several times until a final decision is made to implement the design. The objective is to have
a design that maximizes the network performance, considering the cost constraints and the
required services to be offered to different types of users. After the network has been imple-
mented, network optimization should be performed periodically throughout the lifetime

of the network to ensure its maximum performance and to monitor the utilization of the
network resources.

In this lab, you will design a network for a company that has four departments: research,
engineering, e-commerce, and sales. You will utilize a LAN model that allows you to simulate
multiple clients and servers in one simulation object. This model dramatically reduces both
the amount of configuration work you need to perform and the amount of memory needed
to execute the simulation. You will be able to define a profile that specifies the pattern of
applications used by the users of each department in the company. By the end of this lab, you

will be able to study how different design decisions can affect the performance of the network.

PRE-LAB ACTIVITIES
[ Read Chapter 3 from Computer Networks: A Systems Approach, 5th Edition.

Go to www.net-seal.net and play the following animation:
o Adding Switches

PROCEDURE
Create a New Project

1. Start OPNET IT Guru Academic Edition - Choose New from the File menu.
2. Select Project and click OK = Name the project <your initials>_NetDesign, and the
scenario SimpleNetwork - Click OK.
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Application Config is

used to specify applica-
tions that will be used to
configure users’ profiles.

Profile Config describes
the activity patterns of a
user or group of users in
terms of the applications
used over a period of
time. You must define the
applications using the
Application Config object
before using this object.
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. In the Startup Wizard: Initial Topology dialog box, make sure that Create Empty Scenario

is selected = Click Next = Choose Campus from the Network Scale list > Click Next >
Choose Miles from the Size drop-down menu and assign 1 for both X Span and Y
Span - Click Next twice - Click OK.

Initialize the Network

1.

3.

The Object Palette dialog box should now be on the top of your project space. If it is not

there, open it by clicking . Make sure that the internet_toolbox is selected from the

pull-down menu on the object palette.

Add to the project workspace the following objects from the palette: Application Config,

Profile Config, and a subnet.

a. To add an object from a palette, click its icon in the object palette > Move your mouse
to the workspace - Left-click to place the object. Right-click when finished. The work-
space should contain the shown three objects.

subret_O

Close the Object Palette dialog box and save your project.

Configure the Services

1.

Right-click on the Application Config node - Edit Attributes - Change the name
attribute to Applications - Change the Application Definitions attribute to Default >
Click OK.

. Right-click on the Profile Config node > Edit Attributes - Change the name attri-

bute to Profiles - Change the Profile Configuration attribute to Sample Profiles >
Click OK.

Sample Profiles provides patterns of applications employed by users such as engineers,
researchers, salespeople, and multimedia workers.

Configure a Subnet

1.

Right-click on the subnet node = Edit Attributes - Change the name attribute to
Engineering and click OK.

. Double-click on the Engineering node. You get an empty workspace, indicating that the sub-

net contains no objects.

Open the object palette ﬁ, and make sure it is still set to internet_toolbox.

Add the following items to the subnet workspace: 10BaseT LAN, ethernet16 Switch, and
a 10BaseT link to connect the LAN with the switch = Close the palette.



5. Right-click on the 10BaseT LAN node - Edit Attributes - Change the

6.
7.
8.

LAB 5
Network Design

name attribute to LAN - Observe that the Number of Workstations

attribute has a value of 10. Click in the Value column for the Application:

Supported Profiles attribute, and select Edit. You should get a table in

which you should do the following:

a. Set the number of rows to 1.

b. Set the Profile Name to Engineer. Note: Engineer is one of the
“sample” profiles provided within the Profile Config object = Click
OK twice.

The object we just created is equivalent to a 10-workstation star topol-

ogy LAN. The traffic generated from the users of this LAN resembles that

generated by “engineers.”

Rename the ethernet16 Switch to Switch.
The subnet should look like the shown one.
Save your project.

Configure All Departments

1.

Now you have completed the configuration of the Engineering department subnet.
To return to the main project space, click the Go to the higher level ?/button.
The subnets of the other departments in the company should be similar to the
engineering one except for the supported profiles.

. Make three copies of the Engineering subnet we just created: Click on the

Engineering node = From the Edit menu, select Copy = From the Edit menu, select
Paste three times, placing the subnet in the workspace after each, to create the new
subnets.

. Rename (right-click on the subnet and select Set Name) and arrange the subnets as

shown here:
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7.

. Double-click the Research node - Edit the attributes of its LAN = Edit the value of the

Application: Supported Profiles attribute - Change the value of the Profile Name from
Engineer to Researcher - Click OK twice 2 Go to the higher level by clicking the 9
button.

. Repeat Step 4 with the Sales node and assign to its Profile Name the profile Sales Person.
6.

Repeat Step 4 with the E-Commerce node and assign to its Profile Name the profile
E-commerce Customer.
Save your project.

Configure the Servers

Now we need to implement a subnet that contains the servers. The servers have to support
the applications defined in the profiles we deployed. You can double-check those applica-
tions by editing the attributes of our Profile node. Inspect each row under the Applications
hierarchy, which in turn is under the Profile Configuration hierarchy. You will see that

we need servers that support the following applications: Web browsing, email, Telnet, file
transfer, database, and file print.

1.

2.

Open the Object Palette | and add a new subnet - Rename the new subnet to
Servers - Double-click the Servers node to enter its workspace.

From the Object Palette, add three ethernet_servers, one ethernet16_switch, and three
10BaseT links to connect the servers with the switch.

Close the Object Palette.

Rename the servers and the switch as shown.

Web Server

| Ep—— Servers Switch

Database Server

5. Right-click on each one of the preceding servers and Edit the value of the Application:

Supported Services attribute.

a. For the Web Server, add four rows to support the following services as shown in the
figure: Web Browsing (Light HTTP1.1), Web Browsing (Heavy HTTP1.1), Email
(Light), and Telnet Session (Light).
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(Application: Supported Services) Table.

Name 'Description
Web Browsing (Light HTTP1.1) Supported
Web Browsing (Heavy HTTP1.1)  Supported
Email (Light) Supported
Telnet Session (Light) Supported

b. For the File Server, add two rows to support the following services: File Transfer
(Light) and File Print (Light).
c. For the Database Server, add one row to support the following service: Database Access
(Light).
6. Go back to the project space by clicking the Go to the higher level 2 button.
7. Save your project.

Connect the Subnets S :
seectodes | el

1. Open the Object Palette ] and add four 100BaseT links to connect the |Eﬂ9ineerin93witch ;l
subnets of the departments to the Servers subnet.

Now all subnets are ready to be connected together.
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| Servers Servers Switclﬂ
As you create each link, make sure that it is configured to connect the ancel |[ 0K |
“switches” in both subnets to each other. Do this by choosing them from the
drop-down menus as shown.

2. Close the Object Palette and Save your project.
3. Now your network should resemble the following one:

Applications Profiles

B s FUEES ¥
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Page Response Time
is the required time to
retrieve the entire page.

Choose the Statistics

To test the performance of our network, we will collect one of the many available statistics as
follows:

1. Right-click anywhere in the project workspace and select Choose Individual Statistics
from the pop-up menu.

2. In the Choose Results dialog box, choose the following statistic:

Choose Results

B Global Statistics %

Custom Application

DB Entry

DB Query

Email

Ethernet

Ftp

HTTP

—ll ObjectResponse Time (seconds)
% Page Response Time (seconds) -
—ll Traffic Received (bytes/sec)

— Il Traffic Received (packets/sec)

— Bl Traffic Sent (bytes/sec)

@l Traffic Sent (packets/sec)

e v

< | b

Cancel

3. Click OK.

Configure the Simulation
Here we need to configure the duration of the simulation:
1. Click on the Configure/Run Simulation %] button.

2. Set the duration to 30.0 minutes.
3. Press OK.
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Duplicate the Scenario

In the network we just created, we assumed that there is no background traffic already in the
links. In real networks, the links usually have some existing background traffic. We will create
a duplicate of the SimpleNetwork scenario but with background utilization in the 100BaseT
links.

1. Select Duplicate Scenario from the Scenarios menu and give it the name BusyNetwork -  Link utilization is the
Click OK. percentage of the used
2. Select all the 100BaseT links simultaneously (click on all of them while holding the Shift  link bandwidth.
key) = Right-click on any one of them - Edit Attributes > Check the Apply Changes to
Selected Objects check box.
3. Expand the hierarchy of the Background Utilization attribute = Expand the row 0 hier-
archy > Assign 99 to the background utilization (%) as shown here:

(Research <-> Servers) Attributes

Attribute Value =
@ ~name Research <-> Servi
@ |-model 100BaseT
@ |Fporta Research Switch E:
@ Fportb Servers.Servers Sy
@ [=]Background Utilization () 49
@  Frows 1

[=]row 0

@ I-time (sec) 0.0
@ |- background utilization (%) 99 <€
@ L direction A<>B
@ Ldatarate 100.000.000 -
4| | b

[v Apply Changes to Selected Objects <=—— | Advanced

Find! oK

g4ncel

4. Click OK.
5. Save your project.

Run the Simulation
To run the simulation for both scenarios simultaneously:

1. Go to the Scenarios menu = Select Manage Scenarios.
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2. Change the values under the Results column to <collect> (or <recollect>) for both sce-

narios. Compare to the following figure.

# ‘Scenario Name

Project Name: IEA_NetDes'rgn

Saved Results Sim
/' Duration

Time Units

SimpleNetwork
BusyNetwork

unsaved <collect> 30

unsaved <collect> 30

| Discard Results] Collect Results

Cancel |

minute(s)
minute(s)

0K

3. Click OK to run the two simulations. Depending on the speed of your processor, this task

may take several seconds to complete.

4. After the two simulation runs complete (one for each scenario), click Close.

5. Save your project.

View the Results
To view and analyze the results:

1. Select Compare Results from the Results menu.
2. Change the drop-down menu in the lower-right part of the Compare Results dialog box

from As Is to time_average as shown.

3. Select the Page Response Time (seconds) statistic and click Show. The resulting graph
should resemble the one that follows. (Note: Results may vary slightly due to different

node placement.)

Discrete Event Graphs IDisp!ayed Panel Graphsl

Global Statistics -

HTTP
Page Response Time (seconds)

| Object Statistics \

4 o

Results Generated: 18:03:13 Oct 21 2010

[ Show Preview

003 -

S
time [sec)

|0verfaid Statistics LI IAII Scenarios ;l

Itime_avera ge —

Unselect |

Add

¥
| Show I

Close I
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time_average (in HTTP.Page Response ...

B SimpleMetwark
B BusyNetwork
time_average [in HT TP.Page Response Time [seconds]]

[ [
15m 20m

FURTHER READING
OPNET Configuring Applications and Profiles: From the Protocols menu, select Applications >

Model Usage Guide - Configuring Profiles and Applications. 51

EXERCISES

1.

Analyze the result we obtained regarding the HTTP page response time. Collect four other
statistics of your choice and rerun the simulation of the Simple and the Busy network sce-
narios. Get the graphs that compare the collected statistics. Comment on these results.

. In the BusyNetwork scenario, study the utilization% of the CPUs in the servers (right-

click on each server and select Choose Individual Statistics > CPU - Utilization).

. Create a new scenario as a duplicate of the BusyNetwork scenario. Name the new sce-

nario Q3_OneServer. Replace the three servers with only one server that supports all
required services. Study the utilization% of that server's CPU. Compare this utilization
with the three CPU utilizations you obtained in the previous exercise.

. Create a new scenario as a duplicate of the BusyNetwork scenario. Name the new sce-

nario Q4_FasterNetwork. In the Q4_FasterNetwork scenario, replace all 100BaseT links
in the network with 10Gbps Ethernet links and replace all 10BaseT links with 100BaseT
links. Study how increasing the bandwidth of the links affects the performance of the net-
work in the new scenario (e.g., compare the HTTP page response time in the new scenario
with that of the BusyNetwork).

LAB REPORT

Prepare a report that follows the guidelines explained in the Introduction Lab. The report

should include the answers to the preceding exercises as well as the graphs you generated

from the simulation scenarios. Discuss the results you obtained and compare these results
with your expectations. Mention any anomalies or unexplained behaviors.







