Welcome to the After Effects Illusionist! In this book, we’re going to look at every single native effect in After Effects. But this will not be a duplicate of the After Effects help documentation—far from it. This book is not meant to be comprehensive in the literal sense, meaning that we won’t necessarily cover every single property in every single effect. I think the help documentation does a good enough job of that. We’re instead going to focus on the purpose of each effect, and also how to use it creatively. I’ll also let you know which effects are a waste of time, and if there are any substitutes that work better.

In this chapter, we’re going to get you the foundation you need to understand this book, no matter your skill level. There also may be some tips and tricks in this chapter that can help you as you begin to dig a little deeper into the world of effects.

Why This Book?

I had the idea to create this book after seeing many After Effects users (with far more talent and skill in this arena than I have) doing things manually that could be easily done with the effects that ship with After Effects. Many times, users of After Effects will go back to Photoshop, Illustrator, their video editing application, or their dedicated 3D application to make small changes that could have been done quickly and just as well with effects in After Effects.

The problem is that there are now 189 native effects. Many of them are almost completely worthless. Others might seem worthless or abstract, leaving users to wonder—“When would I ever use this?” This book is my attempt to share with you what I’ve learned in my studies of these effects. The exercise files on the disc that accompanies this book were specifically geared to helping you discover how these effects might help you in your workflow.

How This Book Is Laid Out

In this book, we’re going to examine (among other things) every native effect in After Effects. We’re not going to cover
the effects that sometimes ship with After Effects, such as the Cycore collection of effects, Keylight, Color Finesse and so on. Logistically, it doesn’t make sense to cover so much information in a single volume. But also, it kind of defeats the purpose here. The underlying theme of this book is to demonstrate how much you can do with the native tools at your disposal, without the assistance of third-party effects.

We’re going to cover each effect in each category (e.g., Color Correction, Distort, Generate, and so on) in the order in which After Effects lists them in the Effects menu (and the Effects & Presets panel). After Effects organizes the categories alphabetically, and then the effects in that category are also organized alphabetically as well. And this is the same order that we will follow in this book. So remember that these effects are not listed in the order of importance or sorted in any other way.

After we’ve finished covering all the effects, we’ll have a few appendix-type chapters that cover more intermediate and advanced effects topics, such as using multiple effects, maps to control effect properties, and a brief glance at third-party effect solutions.

**Why Use Effects?**

So, what can effects do? Why use them? First, and perhaps foremost, the effects in After Effects are free, once you have After Effects. They don’t need extra installations or additional serial numbers. There are no compatibility issues with the native effects.

Effects have a wide range of functions. We can use them to create remarkable patterns that can captivate an audience, or that simulate real-world stuff like fire or water. In After Effects, we also adjust color by using effects. But effects can also create simulations, as if something were blowing up or distorting in an organic way. We can access 3D data using effects, and even enhance (and create!) audio using effects. With 189 choices here, and an almost infinite amount of creative combinations, you’re sure to find something to enhance your workflow.

**The Great Secret to the Effects**

If there were one great secret to effects and I had to sum this book up into a single sentence, it would be that effects are sometimes at their best when used for purposes that they were never intended for. We’ll take the Shatter effect (which “blows stuff up,” according to its formal definition), and use it to create volumetric 3D text. In Chapter 7, we’ll sharpen edges using a blur effect, as seen in Fig. 1.1.
In Chapter 5, we’ll use an abstract effect (Shift Channels) to relight a scene rendered from a 3D program using 3D data that is stored in the 3D image. In Chapter 17, we’ll be creating a sci-fi control panel out of video footage of children running using the Brush Strokes effect. This is seen in Fig. 1.2.

We’re going to be creating fireballs and interactive magnifying glasses and lightning and light sabers and armies of objects and realistic flowing chocolate and much more. Of course there aren’t any fireball or chocolate effects. We have to get clever to achieve these results. We have to use effects for purposes that have nothing to do with their names. If ever there were a time to reuse the cliché of thinking outside the box, this is it.

Figure 1.1 These razor sharp edges were sharpened with blur.

Figure 1.2 Applying an effect called Brush Strokes, we create this 60’s sci-fi master computer out of video footage of children playing.
Applies Effects

I’m assuming that you are fairly familiar with After Effects. You’ll certainly get more out of this book if you know more about other (noneffect) aspects of After Effects, such as color channels and color theory, the names of key panels (such as the Composition panel, Project panel, Timeline panel, etc.), layer blend modes, masks, and so forth. But if you are new to After Effects and want to follow along here, you can still learn a lot. So, in this section, we’ll look at how to apply effects.

There are two ways to apply effects—from the Effect menu at the top of the interface or from the Effects & Presets panel. To apply an effect from the Effect menu, select a layer in the Timeline panel, then go to the Effect menu, find the effect in the effects category that you’d like to apply, and then select it there. The problem with this method is that you have to memorize which effects are in which categories. Why would I want to spend time doing that?

I never use the Effect menu to apply effects. I prefer to use the Effects & Presets panel instead. This panel also has effects grouped by preset, but it also has the added power of a live search field. Start typing in a few letters of an effect, and instantly, all effects that have that combination of letters show up in the search results in the Effects & Presets panel, while all other effects are hidden. To remove the search results and see all effects again, click the X on the right side of the search field (Fig. 1.3).

Figure 1.3 Searching for effects in the Effects & Presets panel.
Once you find the effect in the Effects & Presets panel, you can double click to apply. But another benefit of finding effects in this way is that it also gives you drag-and-drop functionality when applying effects. You can drag and drop the effect from the Effects & Presets panel onto the desired layer in the Composition panel or in the Timeline panel.

Adjusting Effects

Once you’ve applied the effect, you adjust its various properties in the Effect Controls panel (on the left side of the interface, grouped with the Project panel by default). If your Effect Controls panel isn’t showing, you can select it from the Window menu, or press the F3 key on your keyboard. We’ll be spending most of this book in the Effect Controls panel, so be familiar with this workflow. Remember that every property that has a stopwatch can be animated (Fig. 1.4).

Resetting Effects and Individual Properties

After experimenting with effects, sometimes you’ll want to get back to the default settings. If you click the Reset button at the top of each effect in the Effect Controls panel, you’ll reset every setting for that effect back to its default value. However, if you want to only reset the value of one property, right click on its value and select Reset.

Figure 1.4 The Effect Controls panel, where we go to tweak effect settings.
Using Effect Presets

Getting the effects settings that are just right can be time consuming. So, After Effects has provided a way for you to save and reuse your effects settings, using effect presets. Effect presets can store the settings of multiple effects and animation data (including keyframes and expressions). For example, let’s say you had created the perfect water texture, comprised of the Fractal Noise effect to make the water texture, the Colorama effect to add color, and you added some expressions to create organic watery movement. You can save all of this work by first selecting all the effects that you want to save in the Effect Controls panel. You can select multiple effects by holding down the Ctrl(Win)/Cmd(Mac) key while clicking to select them. Then, with the effects selected, open the Animation menu at the top of the screen and select Save Animation Preset. You can then navigate to a location to save the preset, which has a .ffx file extension. To apply an effect preset, simply select the layer(s) to which you want to apply the preset, open the Animation menu and select Apply Animation Preset, navigate to and select the desired FFX file, and click OK. Note that these FFX files are also cross-platform.

The Effects & Presets panel can also display effect presets that ship with After Effects, or that are stored in the same folder as the stock presets. That way, when you perform a search, you can use this panel to access presets and apply them quickly. Personally, I find this to be a distraction, especially when teaching. So, I go to the Effects & Presets panel menu and deselect the Show Animation Presets option (Fig. 1.5).

Browsing Effects Presets with Adobe Bridge

Adobe Bridge is a file browsing application that comes with After Effects and many other Adobe programs as well. It can preview still images (including image sequences!), graphics from Adobe Illustrator, video, audio, PDFs, layered Photoshop documents, and even some 3D files. One of the lesser known features of Adobe Bridge is that it can also preview the animation presets that ship with After Effects. This even includes the ability to preview the text animation presets.
The presets are kinda buried on your hard drive. They're located in the Presets folder in the After Effects folder in the Adobe folder in the Program Files (Win)/Applications (Mac) folder on your computer. However, there's a nifty shortcut for getting Bridge to the presets folder. Go to the flyout menu of the Effects & Presets panel (the same place where we deselected the Show Animation Presets option in the previous section), and choose Browse Presets. This will not only launch Adobe Bridge (assuming it isn't running already), but it will also automatically navigate to the Presets folder for you. In Bridge, you'll then see the contents of the Presets folder, which contains a large number of folders of preset categories (Fig. 1.6).

If we double click one of the folders—Backgrounds in this case—we'll enter that folder and see previews of all of its animation presets (Fig. 1.7).
Remember that animation presets can contain animation, and so can their previews. Click a preview once in Bridge to select it. It will then display a larger preview in the Preview panel on the right-hand side of the interface. It will have its own scrubbable timeline (Fig. 1.8).

![Figure 1.8 When a preset is selected, you can get a larger, animated preview in the Preview panel in Adobe Bridge.](image)

To apply an animation preset from Bridge, just double click it in Bridge. This applies to text animation presets as well.

**Using Brainstorm with Effects**

Introduced in After Effects CS3, Brainstorm allows you to see random variations of settings. This is particularly helpful with effects. You can even select multiple effects in the Effect Controls panel and see random variations of all the properties of both effects. Or, in the Timeline panel, you can select just one parameter of an effect to see random versions of the effect, with only that property changing.

I’m going to create a new solid layer by going to the Layer menu at the top of the interface and choosing Layer> New> Solid. You can also create solid layers by using the keyboard shortcut Ctrl+Y (Win)/Cmd+Y (Mac)—a useful shortcut to memorize for going through this book. I’ll then apply the Fractal Noise effect, followed by the Tritone effect. Next, I’ll select both effects in the Effect Controls panel using the Ctrl (Win)/Cmd (Mac) key. Now I’m ready to have Brainstorm create some random results for me. Click the Brainstorm icon at the top of the Timeline panel. Brainstorm used to have the coolest icon of all time (A big brain...
with a lightning bolt—get it? BRAIN/STORM! Ha! I loved it!), but now it just looks like a thought bubble with a light bulb (Fig. 1.9).

After clicking the Brainstorm icon, the Brainstorm feature opens up, giving you nine variations of these two effects (Fig. 1.10).

By default, the Randomness value is set to 25%. But I want to give Brainstorm a more creative license, I’m going to up that value to 100%. To see nine more variations with our current settings, click the Brainstorm button (Fig. 1.11).

You can continue to click the Brainstorm button, which will give you nine more variations each time. Once you’ve found a pattern you like, hover your cursor over the pattern to get access to four important options (Fig. 1.12).
Chapter 1 BECOMING AN ILLUSIONIST

Clicking the leftmost button will maximize a pattern (Fig. 1.13). The second button (that looks like a disc icon) is used for when you've found a pattern that you like but don't want in your current composition. Click this icon to have After Effects create a new composition and a new solid with these effects applied with these settings. When you've completed your work with Brainstorm, you'll find the new comp waiting for you in the Project panel.

The third button from the left (with a checkmark) indicates that you've found the exact settings you're looking for. Clicking this button will close Brainstorm and change the settings of Fractal Noise and Tritone to match the pattern you selected in Brainstorm.

The button on the far right is Include in Next Brainstorm. This is your way of telling Brainstorm that it's getting close to something you like. Click this button, then click the Brainstorm button.

Figure 1.12 Hovering your cursor over one of the results gives you four buttons.

Figure 1.13 Maximize a pattern by clicking the first button on the left.
again to get nine more variations that are similar to the one you’ve
selected. To make these nine variations closer to the one you’ve
selected, take down the Randomness value. You can also include
multiple patterns in the next Brainstorm, if you choose.
You can also go back and forth to previous groups of
Brainstormed patterns by clicking the back (left arrow) button
to the right of the Brainstorm button. Brainstorm also works on
animated effects. Click the play button in the Brainstorm win-
dow to see what your animations look like with the new patterns
(Fig. 1.14).

Figure 1.14  Telling Brainstorm
that you want to include a
pattern in the next iteration of
Brainstorming tends to make
other patterns like the one you’ve
chosen. Note that I’ve also taken
down the Randomness value
to 20%.

Note that you can also use Brainstorm as a way to learn After
Effects. If you’re not sure what a certain property or effect can do,
simply select it, then open Brainstorm. It will only give you ran-
dom versions of the properties or effects that you’ve selected.
That way, you can more clearly see what that particular effect or
value does.

Common Effect Parameters
Some properties in effects are seen all over the place. Just so we
don’t have to repeat the same information over and over, let’s get
familiar with a few of them here.

Effect Control Points
Many effects will have something called an effect control
point for certain values. These indicate a point with an XY axis
(Fig. 1.15).
Effect control points can be adjusted in three ways. You can simply adjust the X-and Y-dimension hot text values in the Effect Controls panel, as you would any other values. You could also click the effect control point icon in the Effect Controls panel, then click the desired location of the effect control point in the Composition panel. Finally, you can also manually adjust the effect control point in the Composition panel by using the effect control point icon. This icon looks like a circle with a plus sign in the middle. Note that effect control points can also be targeted by the motion tracking system in After Effects (Fig. 1.16).

Random Seed

The Random Seed parameter creates randomization using the same settings that you already have. At first, this may seem confusing. How can it match your exact settings and also be random at the same time?

Think of it this way. Let’s say that you and some friends were going to get dinner together. After a few hours of arguing, you
decide that you are going to get pizza. Perhaps you even narrow it down to a pizza with some type of meat on it. So, you send out one of your buddies to go get the pizza and bring it back home. Upon their return, they inform you that they brought back a pizza with extra anchovies. Yuck! They followed your instructions to the letter—a pizza with meat. But that's not what you had in mind. So you might send your buddy back to the pizza place to pick up another pizza using your same criteria.

This is a lot like using Random Seed. It keeps all the settings of the effect unchanged (like your rules for dinner—pizza with meat), and then gives you variations of the effect based on those settings. Random Seed is great if a pattern is created that has an element in the wrong spot or if you just want to rearrange things a bit.

**Composite on Original**

Composite on Original settings come in many forms. A similar property might be called Blend with Original, Opacity, or something similar. Basically, this allows the effect to blend in with the original layer. If you applied Fractal Noise to a layer with video to create a fog effect, you might change the blend mode or lower its Opacity value.

Personally, I prefer the power of having effects on their own independent layer so that I can adjust them as I please without affecting my source footage. This is why I frequently use solid layers so that I can keep my effects as autonomous layers.

**About the Artbeats Footage**

The stock video powerhouse, Artbeats.com, has graciously provided some great stock video clips for us to use in this book. They can be found in the Artbeats folder in the Media folder in the exercise files that are on this disc. The versions that I will be using in my screenshots will be at full video resolution. Note that the versions included on the disc are half size (320 × 240 pixels), and are also watermarked. If you care to purchase the full-resolution clips, you can find the clips of the same name (and many more) on Artbeats.com.